Deploy Rasa Bot on Cloud Run - Getting Started with Rasa / Tutorials, Resources & Videos - Rasa Community Forum
Deploy Rasa Bot on Cloud Run
post by souvikg10 on Jun 10, 2021
Hi there,
Just created a small example on how to deploy your chatbot on Google Cloud Run which offers 2Gi containers in their free tier with concurrency as well as volume.
Free feel to reach out to me if you have any questions
post by BELIEVEIT on Jun 14, 2021
Hello souvijk, Thanks for the README file I tried following the instruction for deployment but getting error, tried a few solutions e.g adding RUN CHMOD 755 +x in the Dockerfile, but still does not resolve the error
. Hope that you can help me out. Thanks
post by souvikg10 on Jun 14, 2021
Do it in your machine. Running chmod within Dockerfile won’t work.
Change permissions and then build
If you clone my repo, the permissions are already up to date
post by BELIEVEIT on Jun 15, 2021
I cloned the repo from GitHub and still facing the same error invalid Entry point ):
post by souvikg10 on Jun 15, 2021
Changed the file’s permission on your machine first before building the docker image
Remove all images that were created earlier because it might be using docker cache
post by BELIEVEIT on Jun 15, 2021
Thanks souvikg, may I know how do we clear the image in docker cache? First time using docker here.
post by souvikg10 on Jun 15, 2021
When you run the commanddocker images, you might see a lot of images with the name none; you can remove them.
docker rmi -f ID
where ID is the id of the images without any names and it named as none. These might be images which is caching the layers.
post by BELIEVEIT on Jun 15, 2021
After much attempt I still failed to deploy but I can see the service in Cloud Run.
I had tried giving auth. user full access control through properties and also icacls /grant Everyone:F /t
post by souvikg10 on Jun 15, 2021
Could you do an ls -ltr on the cloned repository. If it has the correct permissions it would look like this
-rwxrwxr-x 1 souvik souvik 32 Jun 10 23:44 entrypoint.sh
Of course a different user:group for you
If not try thischmod +x ./entrypoint.sh
post by Fadi on Nov 15, 2022
Hi Souvik, I am following your documentation to deploy Rasa on Cloud Run using the CICD. As soon as I commit my code in GitHub, the build trigger fail with following error below. Can you help with this? Thanks
BUILD
Starting Step #0
Step #0: Already have image (with digest):
Step #0: unable to prepare context: unable to evaluate symlinks in Dockerfile path: lstat /workspace/Dockerfile: no such file or directory
Finished Step #0
post by souvikg10 on Nov 17, 2022
Do you have the dockerfile in the correct path?
post by bricemacias on Feb 13, 2023
Worked perfectly for me - cloning repo, following readme (enabling cloud run, setting IAM permissions, and deploying), even with my own postgres tracker store endpoint and last rasa version (3.4)
Thanks a lot !
post by WojtekPachowiak on Apr 13, 2023
If someone has an error like this:
Container failed to start. Failed to start and then listen on the port defined by the PORT environment variable.
Then here’s the solution:
ubuntu - Docker error on an entrypoint script: "no such file or directory" - Stack Overflow
It’s about line endings