Action server not connect in RASA : Docker - Rasa Open Source - Rasa Community Forum

👋 Introducing the Rasa Playground

Action server not connect in RASA : Docker

post by sriram on Sep 11, 2020

Hi,

I am facing issue when adding custom actions using docker. Deploy the RASA using Docker followed below document
https://rasa.com/docs/rasa/user-guide/docker/building-in-docker/#using-docker-compose-to-run-multiple-services

Error: Couldn’t connect to the server at ‘ http://action-server:5055/webhook’. Is the server running? Error: Cannot connect to host action-server:5055 ssl:default [Name or service not known]

post by rctatman on Sep 11, 2020

Ah, I was just talking with someone else about something similar. Does something like “ http://example.com/core/webhooks/rest/webhook” work? (Here’s the discussion: How to post to rasa server after Rasa X Deployment)

Related topics

Topic Replies Views Activity
Docker: Couldn’t connect to the action server but it is running 1 1.0k Nov 2021
Action server not working with Docker: Couldn’t connect to the server 12 4.0k Apr 2020
Rasa won’t connect to action server 22 10.0k Feb 2022
Error unable to connect action server in docker 22 2.1k May 2022
Action server in docker-compose cannot communicate with rasa server properly 2 236 Feb 2024